I suggest you ...

Copy code for build needs to improve to handle more scenarios

I love working with your engine, and will say that this is the best one I've ever encountered in terms of architectural perfection for coding games.

On my Windows 10 system tried Wave Engine 2.3.0, 2.4.0 and 2.4.1. Every-time when I try to build and run via the Wave-Editor or via Visual Studio, it ends up in build failure because of "File not found" exception. I investigated into the issue and found that the copy of scene and game contents like wgame and wscene + asset files are not working through the xcopy commands running during the build time. So, I had to write the .ps1 script and place-in a generic pattern to manually copy the contents into the respective Debug, etc. directories. Then when I hit Build and run again the project compiles and runs from Wave-Editor and Visual Studio too.
Hence, I will request to add up some more code around copying function that can check the OS scenarios and create some fail-safe content-copy methods for builds.

3 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • sso
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Rahul Mistry shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • sso
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base